1

Resolved

type or namespace error when creating ribbon custom action

description

Just started using your plug-in. I created a new project as per the instructions and created a new custom action for a ribbon button. Once Visual Studio completes its initial configuration and spits the code into the .cs file and elements.xml file I get an error on build. The error states the type or namespace for 'SubMenuTemplate' could not be found. How do I resolve this? What am I missing? I have included a screenshot on my Solution Explorer.

file attachments

comments

matein78 wrote Oct 21, 2012 at 10:20 AM

SubMenuTemplate is a class in the Microsoft.SharePoint.WebControls namespace.It should be automatically included in the namespaces section of the class.

Have you checked if your reference in the project to Microsoft.SharePoint.dll is working?

pivotalsolution wrote Oct 22, 2012 at 2:25 PM

here are my references:using System;using System.Collections.Generic;using System.Text;using System.Web.UI.WebControls;using Microsoft.SharePoint;using Microsoft.SharePoint.WebControls;

My Solution Explorer:References include the following SharePoint assemblies:Microsoft.SharePointMicrosoft.SharePoint.Security

Am I missing anything?

pivotalsolution wrote Oct 22, 2012 at 5:44 PM

here are my references:
using System;    using System.Collections.Generic;    using System.Text;    using System.Web.UI.WebControls;    using Microsoft.SharePoint;    using Microsoft.SharePoint.WebControls; 
My Solution Explorer:References include the following SharePoint assemblies:
Microsoft.SharePoint    Microsoft.SharePoint.Security 
Am I missing anything?

matein78 wrote May 28, 2013 at 2:55 PM

Fixed in SharePoint Software Factory 4.1.3