This project is read-only.

System.Runtime.InteropServices.COMException (0x80020003): Member not found.

Oct 12, 2010 at 5:32 PM

I have two clean servers that are receiving the same error. 

Server 1:
Windows Server 2003 R2 x86
MOSS 2007

Server 2:
Windows Server 2008 R2 x64

(The only variation in the installation is that I used Style Cop 4.4 rather than 4.3.)

Everything installs without error.  But when I try to create a SPSF project (either 2007 or 2010), the project creation fails with this error:

System.Runtime.InteropServices.COMException (0x80020003): Member not found. (Exception from HRESULT: 0x80020003 (DISP_E_MEMBERNOTFOUND))
   at EnvDTE.SelectedItem.get_Name()
   at Microsoft.Practices.RecipeFramework.VisualStudio.Library.DteHelper.GetTarget(_DTE vs)
   at Microsoft.Practices.RecipeFramework.VisualStudio.Templates.UnfoldTemplate.SetUnfoldingRoot()
   at Microsoft.Practices.RecipeFramework.VisualStudio.Templates.UnfoldTemplate.RunStarted(Object automationObject, Dictionary`2 replacementsDictionary, WizardRunKind runKind, Object[] customParams)


Oct 12, 2010 at 7:12 PM

I discovered that this error only occurs when I am connected to a Team Foundation Server.  No error occurs when I am disconnected.  This problem has been reported in other Guidance packages such as the Web Service Software Factory, with no posted resolution.


Oct 12, 2010 at 8:18 PM

I was able to reproduce the problem on VS2010 with TFS2010 as well as VS2008 with TFS2008. In both configurations the same problem occurs during project creation.

I also installed the Microsoft Guidance Automation Toolkit (which is also a Guidance Package) with the same behaviour: If VS is connected to TFS the creation of projects fails with "Member not found".

This issue could be a general problem of all guidance packages in VS2010 and VS2008. As we cannot fix it currently we will include this issue into our FAQs and documentation and will recommend to disconnect from TFS temporary if the problem occurs.

@jpalmerOPTR: Thank you for your support.

Oct 12, 2010 at 9:14 PM

Thanks for your help.  I can work around this apparent non-SPSF issue.  I'll let you know if I find any additional information.

Oct 14, 2010 at 3:26 PM

I tried to reproduce the error as well but couldn't :-)


Dev Server:
- Windows 2008 R2
- SharePoint 2010
- VS2010
- SPSF 3.0.2

TFS Server:
- Windows 2008 R2
- TFS2010

Use Cases (both while connected to TFS)

1. Create SharePoint 2010 Application with SPSF2010 and "Add to Source Control" checked
2. Create SharePoint 2010 Application with SPSF2010 and "Add to Source Control" unchecked and added to source control manually after SPSF finished its job

were both successful.

So maybe this is a configuration issue of TFS or VS?


Oct 14, 2010 at 3:35 PM

The problem appeared for me when the "source control explorer" from a TFS team project is opened in VS during project creation. Only opening the Team Explorer produced no problems. Same behaviour for VS 2010 and VS 2008.

Apr 7, 2011 at 12:45 PM

We added a warning to SPSF 3.1 when you want to create a new project with Source Control Explorer opened and with a node selected.

Though, the error will be still shown afterwards as we cannot prevent VS from that :-(