DLL missing in VS2013 on creating publishing site definition via SPSF artefact

A error occurs If I create a publishing site definition via SPSF artefact in VS2013: Error was: Action AddOnet failed to execute: Could not load file or assembly 'Microsoft.VisualStudio.TextTempla...

Id #7696 | Release: None | Updated: Nov 10 at 12:10 PM by Hypopheralcus | Created: Dec 2, 2013 at 10:36 PM by matein78

Remove FixPackateManifestTask

When building any solution with VS 2012 and SharePoint 2013 (German Version) I get the following errors: Fehler 1 Unerwarteter Fehler bei der FixPackageManifestTask-Aufgabe. System.ArgumentExcepti...

Id #7645 | Release: SPSF SharePoint Software Factory 4.1 (VS2012-2013) | Updated: Aug 26 at 10:35 AM by matein78 | Created: Oct 28, 2013 at 10:30 PM by matein78

Generated code should not raise StyleCop warnings

Code generated through SPSF should not result in StyleCop (or FxCop/SpCop) errors, as with the delivered default settings. For example creating a new Item Event Handler results in: SA1126 : The c...

Id #7580 | Release: None | Updated: Aug 29, 2013 at 10:56 AM by pberger | Created: Aug 29, 2013 at 10:56 AM by pberger

$SharePoint.Project.AssemblyFullName$ Token not replaced

As already discussed in the forum (https://spsf.codeplex.com/discussions/446741) by another user, it seems like the $SharePoint.Project.AssemblyFullName$ token is no longer replaced using SPSF. In ...

Id #7579 | Release: None | Updated: Aug 21 at 2:06 PM by danielsirz | Created: Aug 29, 2013 at 8:31 AM by pberger

Assembly Version not correct for Event Receivers

If I use the Item Event Receiver receip it results in an ELemnts.xml with Assembly names without version: MyCompany.MyProject.Components, Version=, Culture=neutral, PublicKeyToken=xxxxxxxxxxxxxxxx...

Id #7578 | Release: None | Updated: Aug 29, 2013 at 8:30 AM by pberger | Created: Aug 29, 2013 at 8:30 AM by pberger

SharePoint 2010 project requires SharePoint 2013 Dev Tools

I tried using SPSF on a computer with SharePoint 2010 and VS 2012. After creating a new Sharepoint 2010 project I get an error message "This Project targets Office or SharePoint 2013. Please instal...

Id #7576 | Release: SPSF SharePoint Software Factory 4.1 (VS2012-2013) | Updated: Aug 27, 2013 at 1:35 PM by matein78 | Created: Aug 27, 2013 at 8:09 AM by pberger

ListDefinition - Direction as private resource

When creating a new list definition this string is used in the schema.xml: Direction="$Resources:Direction;" You should better use the core resources instead an change this to Direction="$Resou...

Id #7510 | Release: SPSF SharePoint Software Factory 4.1 (VS2012-2013) | Updated: Jul 10, 2013 at 1:42 PM by OWirkus | Created: Jul 5, 2013 at 9:52 AM by OWirkus

'Solutions' folder was not created

Hi guys, 'Solutions' folder was not created after upgrading the solution or project as it is described in the released documents. Cheers !

Id #7501 | Release: None | Updated: Jun 28, 2013 at 8:52 AM by matein78 | Created: Jun 26, 2013 at 3:37 PM by dominik78

Deployment project can't build when located in a subfolder

Hi, I found a bug in the deployment project. In our current solution, I have added a deployment project. But I couldn't get it to work because the deployment project is located in a subfolder. St...

Id #7472 | Release: SPSF SharePoint Software Factory 4.1 (VS2012-2013) | Updated: Jun 3, 2013 at 9:50 PM by matein78 | Created: Jun 3, 2013 at 9:48 PM by matein78

Recipe Blank Site Definition fails

Thanks for the new Version, I'd installed it. But when I try to add a "Blank Site" component the following Crash happens, and yes I'd installed the brand new Version from yesterday, as you told me ...

Id #7465 | Release: SPSF SharePoint Software Factory 4.1 (VS2012-2013) | Updated: Nov 18, 2013 at 9:49 AM by theodor_elektron | Created: May 29, 2013 at 3:35 PM by matein78