Error creating any Field

Oct 17, 2012 at 10:36 AM
Edited Oct 17, 2012 at 11:33 AM

SPSF 3.2 Version

When I create a field always the error is fired. Can someone help me with this?

Field name is: FGeneralImage

Thanks

System.Xml.XmlException: Name cannot begin with the ''' character, hexadecimal value 0x27. Line 2, position 66.
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.Throw(String res, String[] args)
   at System.Xml.XmlTextReaderImpl.ParseQName(Boolean isQName, Int32 startOffset, Int32& colonPos)
   at System.Xml.XmlTextReaderImpl.ParseElement()
   at System.Xml.XmlTextReaderImpl.ParseElementContent()
   at System.Xml.XmlTextReaderImpl.Read()
   at System.Xml.XmlLoader.LoadNode(Boolean skipOverWhitespace)
   at System.Xml.XmlLoader.LoadDocSequence(XmlDocument parentDoc)
   at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
   at System.Xml.XmlDocument.Load(XmlReader reader)
   at System.Xml.XmlDocument.LoadXml(String xml)
   at SPALM.SharePointSoftwareFactory.Library.Helpers2.AddFile(DTE dte, ProjectItems whereToAdd, String targetFilename, String content, Boolean overwrite, Boolean open)

Oct 18, 2012 at 11:44 AM
jlivio wrote:

SPSF 3.2 Version

When I create a field always the error is fired. Can someone help me with this?

Field name is: FGeneralImage

Thanks

System.Xml.XmlException: Name cannot begin with the ''' character, hexadecimal value 0x27. Line 2, position 66.
   at System.Xml.XmlTextReaderImpl.Throw(Exception e)
   at System.Xml.XmlTextReaderImpl.Throw(String res, String[] args)
   at System.Xml.XmlTextReaderImpl.ParseQName(Boolean isQName, Int32 startOffset, Int32& colonPos)
   at System.Xml.XmlTextReaderImpl.ParseElement()
   at System.Xml.XmlTextReaderImpl.ParseElementContent()
   at System.Xml.XmlTextReaderImpl.Read()
   at System.Xml.XmlLoader.LoadNode(Boolean skipOverWhitespace)
   at System.Xml.XmlLoader.LoadDocSequence(XmlDocument parentDoc)
   at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
   at System.Xml.XmlDocument.Load(XmlReader reader)
   at System.Xml.XmlDocument.LoadXml(String xml)
   at SPALM.SharePointSoftwareFactory.Library.Helpers2.AddFile(DTE dte, ProjectItems whereToAdd, String targetFilename, String content, Boolean overwrite, Boolean open)

I Just installed a new Server From Scratch with:

  • Windows Server 2008 R2 Full Updates
  • SQL Server 2008 R2 with SP2
  • VS 2010 Utlimate no Extensions

Now the problem is only with the IMAGE Type

Any help on this? thanks very much

Joao

Coordinator
Oct 21, 2012 at 9:45 AM

Thanks for your bug report.

I could reproduce the issue with the Image type and will look into it for the next version we are currently creating.
BR

Matthias

Coordinator
Oct 21, 2012 at 9:46 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.