This project is read-only.

Class name of feature receiver

Apr 7, 2011 at 1:15 PM

It would be nice if one could specify the class-name of the created feature-receiver. Currently the name is created from the name of the feature (and the filename cannot be changed easily within VS).

E.g. if my feature is named "Core" the corresponding class of the feature-receiver is also named "Core" (Company.Project.Core). I would like to use CoreFeatureReceiver as class name although the naming might be redundant because it derives from SPFeatureReceiver.

Greetings and thx for spfs!

Apr 11, 2011 at 7:19 AM

Good point.

We should append "EventReceiver" to the name of the class because VS 2010 use this naming convention.

I would not make the class name configurable because we argue that SPSF forces the implementation of naming conventions. Better, we change the naming convention. :-)

What do you think?


Apr 19, 2011 at 8:27 AM

I'm a fan of convention over configuration. So adding "EventReceiver" to the class name is the best!


Apr 19, 2011 at 3:57 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.